Metainformationen zur Seite

Node.js V12 auf Pi 1 / Pi Zero

Problem

Die mit LoxBerry 2.x mitgelieferte Node.js Version 12 (LTS) funktioniert nicht auf Raspberry Pi 1 und Raspberry Pi Zero.

Plugins, die Node.js benutzen und auf einem Raspberry Pi 1 / Zero laufen, funktionieren nicht oder nicht vollständig.

Ursache

Node.js liefert keine Pakete mehr für ARMv6-Architektur aus, daher läuft Node.js auf diesen alten Raspberry's nicht mehr. 

Lösung

  • Einen neueren Raspberry kaufen (Pi 2 aufwärts)
  • Node.js V12 manuell deinstallieren, und Node.js V10 manuell installieren

Das Installieren von Node.js V10 passiert „auf eigene Gefahr“ und ohne unseren Support. Wir können nicht garantieren, dass dein Raspberry die manuelle Installation überlebt, und die Plugin-Entwickler können nicht garantieren, dass mit der älteren Node.js-Version die Plugins korrekt funktionieren.